Gateways unresponsive on uk-1.platform.sh
Incident Report for Platform.sh
Postmortem

What happened

A surge in incoming connections to the uk-1.platform.sh region rendered the gateways unresponsive, affecting the availability of sites and environments within the region.

This incident did not affect Dedicated clusters.

Customer Impact

During the incident, which commenced at 07:23 UTC on 2024-03-29, certain sites in the uk-1.platform.sh region experienced unavailability.

Sites were restored within 10 minutes, with normal operations resuming by 07:33 UTC.

What was done to resolve the incident

To mitigate the impact, we swiftly implemented measures to block the majority of the malicious (DDoS) traffic targeting the region.

Short term mitigations

Our engineering team is actively analyzing the attack patterns to fortify the resilience of our incoming request gateways, including reviewing rate limit configurations and adding further gateway capacity.

Posted Mar 29, 2024 - 09:20 UTC

Resolved
This incident has been resolved.
Posted Mar 29, 2024 - 08:15 UTC
Monitoring
A large increase in incoming connections to the uk-1.platform.sh region caused the gateways to become unresponsive.

Traffic has been blocked and we're seeing gateway performance returning to normal. We're continuing to monitor the situation and will take additional action if needed.
Posted Mar 29, 2024 - 07:41 UTC
This incident affected: United Kingdom (uk-1.platform.sh).